Cómo configurar un Mikrotik para usar la vlan3 de voip de Movistar FFTH

26 Feb

Para los que la vozip es una pasión, lo de usar la voz mediante el puerto FXS de la ONT se nos queda pobre, mucha gente para integrar líneas de FFTH en centralitas suele usar un adaptador FXO conectado al FXS , y de esta forma integrarlo en la centralita IP.

Pero esto aunque funciona no es lo óptimo, porque gastarse más dinero en gateway cuando podemos atacar directamente a la plataforma de Movistar a nivel SIP.

Para ello podemos hacer dos cosas, conseguir migrar de alguna forma a sbc.ngn.rima-tde.net nuestra cuenta de fijo, por ejemplo una de las vías es apuntarse a la beta de Mi Fijo 2.0 que conté hace unos días y solicitar el poderla usar fuera de la conexión de fibra. Nos proporcionarán un usuario y en un post posterior mostraré como configurarlo con una centralita comom Asterisk.

La segunda sería sustituir el router de Movistar y atacar directamente con un Mikrotik. Para ello debemos crear dos vlanes (6 Datos y 3 Voz) , si dispusiéramos de Movistar TV haría falta configurar la vlan2 también, pero eso es otro asunto.

Os muestro la configuración necesaria a continuación.

Creamos las dos vlanes:

add interface=ether1-ont-casa l2mtu=1594 mtu=1594 name=vlan3 vlan-id=3

add arp=proxy-arp interface=ether1-ont-casa l2mtu=1594 mtu=1594 name=vlan6 \
vlan-id=6

Habilitar cliente DHCP por la vlan3

add add-default-route=no dhcp-options=hostname,clientid disabled=no \

interface=vlan3 use-peer-dns=no use-peer-ntp=no

Permitir tráfico vlan3 por el firewall y realizar NATeado

/ip firewall filter

add chain=input in-interface=vlan3

add chain=output out-interface=vlan3

add action=masquerade chain=srcnat out-interface=vlan3

Habilitar los SIP ports

/ip firewall service-port

set sip ports=5060,5061,5070

Y añadir las reglas de rutado por la vlan3

/ip route

add distance=1 dst-address=10.31.255.128/27 gateway=10.22.0.1%vlan3 \
routing-mark=to_vlan3

/routing rip interface

add interface=vlan3 passive=yes receive=v2

/ip firewall mangle

add action=mark-connection chain=prerouting dst-address=10.31.255.128/27 \

in-interface=bridge-local new-connection-mark=voip_vlan3 src-address=\

10.0.1.8 (Aquí la 10.0.1.8 es una centralita IP o teléfono IP)

add action=mark-routing chain=prerouting connection-mark=voip_vlan3 \

in-interface=bridge-local new-routing-mark=to_vlan3

add action=mark-routing chain=output connection-mark=voip_vlan3 \

new-routing-mark=to_vlan3

y luego las rutas corresponidentes

/ip route

add distance=1 dst-address=10.31.255.128/27 gateway=10.22.0.1%vlan3 \

routing-mark=to_vlan3

Con esto cuando vayamos a registrar un teléfono IP o centralita, usaremos los datos

IP de registro: telefonica.net:5060

Proxy: 10.31.255.134:5070

Usuario: 9XXXXXXXX

Password : 9XXXXXXXX ( El mismo número)

Codecs Soportados: G722, G711 , G729 ,H264,H263 y H263p

Cualquier duda, dejarla en comentarios

3CX lanza su plataforma de Videoconferencia basada en WebRTC

29 Aug

webrtc

3CX lanza su Webmeeting que ofrece soporte de videoconferencia basado en WebRTC. Este nuevo producto está totalmente integrado en 3CX y permite realizar videoconferencias con hasta 100 participantes. Eso sí se trata de un producto comercial y los precios van dependiendo del número máximo de participantes como muestro a continuación:

  • 10 participantes – $495/€395
  • 25 participantes- $995/€795
  • 50 participantes – $1750/€1395
  • 100 participantes- $2995/€2395 Existe un descuento de 30 % hasta Septiembre.

El producto se trata de un add-on por lo que es añadido a nuestro sistema actual 3CX .

Para más información visitar http://www.3cx.com/web-conferencing/

Line introduce la videollamada

24 Sep

En su dí­a Fring fue la primera aplicación que lo soportaba, posteriormente fue Skype la que más se expandió, Viber fue de las últimas en incorporarlo, pero la videollamada todaví­a sigue siendo ese caballo de batalla que no termina de despegar, porque la gente , ya no prefiere ni siquiera la voz, si no los mensajes escritos como forma de comunicación.

Todo ha cambiado, la videollamada fue por lo que se justificó el salto a 3G, ahora con 4G podrí­amos tener videollamadas en 3D pero no hay demanda..

Line ahora lo lanza, adelantándose a Whastapp.. será un cambio de tendencia? Con el tiempo lo veremos

Ví­a Alt1040

RTC Video en Android

2 Apr

I6net esta probando su Video Softphone SDK allá donde encuentra 😉 y ha estado probandolo en un pequeño Smartv basado en Android de la marca bluesens. Ya se puede tener videoconferencia en un smartv sin tener que recurrir a skype 😉

Más información en http://www.i6net.com/2013/04/02/rtc-over-android-smarttv-mini-video/

Polycom adquiere Vivu

19 Oct

Polycom ha anunciado que ha cerrado la adquisición de la empresa de videconferencia en web Vivu.

No se han dado datos de precio pagado, y Polycom ha adelantado que seguirá por el momento manteniento el modelo de negocio de Vivu, que en la actualidad consta de 25 empleados.

Ví­a Networkworld

Qik Video Connect

30 Apr

Hasta ahora , para hacer videollamadas entre android e iphone, o bien usabas la videollamada 3G, la cual he usado 3 veces en mi vida, o bien usabas aplicaciones como Tango, que está para IOS de apple y android.

Ahora se añade una más al juego, que es Qik Video Connect.

Es gratis hasta Junio y simplemente hace falta tener una cuenta en qik.

De este modo se añade una funcionalidad más, de videochat, a la plataforma de compartir ví­deos de forma instantánea y streaming de QIK.

Lo he probado entre un iphone 3G , soporte notificacií²n PUSH, y un Samsung Galaxy S. Funciona bastante bien , la única pega es que en el SGS la cámara frontal no va en 2.2.2

Parece que si va en 2.3.3

El link para android lo tenéis aquí­

Más información en Qik

La videollamada sigue expandiéndose. Gtalk Video para Android

30 Apr

Google ha presentado en el Google I/O la versión para Android 2.3.4 de Google Voice con ví­deo.

Después del movimiento de Apple con Facetime, de Fring que lleva ya tiempo y acaba de presentar su versión de videollamada a 4 personas, falta que Google hiciera lo propio trasladando esta facilidad a su aplicación de móviles, la cual ya estaba hace tiempo para sistemas Windows y Mac.

Es posible instalarla si tenéis 2.3.3 en Samsung Galaxy S, siguiendo este procedimiento

Tango: Videollamada entre iPhone y Android

6 Oct

Si tu mujer, tu amigo , tu jefe tiene un iphone, pero tu eres más de android, ahora puedes tener videollamadas entre las dos plataformas, y tanto por Wifi como 3G con la aplicación Tango.

En la appstore puedes localizarla, así­ como en android Market .

Periódicamente busca en tu agenda, por si hay usuarios de Tango, y te permitirá videollamar simplementa pulsando sobre el número, como si de una llamada normal se tratase. Al igual que con facetime, cuando tengas la llamada activa, podrás conmutar a ví­deo.

Aquí­ tenéis un ví­deo para ir abriendo boca.

Videoportero Mobotix T24 Hemispheric IP Door Station

30 Jun

Mobotix lanza un interesante y potente videoportero con SIP, H264 y G711 con cámara hemisférica de 180 grados.

Permite grabar “videollamadas” a SD, apertura de puertas, reproducción de mensajes vocales de forma automático y predefinidos, o bien apertura de puertas sin llave.

A tenor del manual, es bastante potente, y habrá que ver en que entornos de precios anda, ya que las cámaras mobotix suelen ser bastante altas en este aspecto.

La videollamada está introduciéndose poco a poco, ahora bien los videoporteros SIP IP no parece que se quedarán atrás.

Podéis ver el datasheet del producto aquí­

y apple abrió los ojos a la videoconferencia…

8 Jun

Los que llevamos ya tiempo trabajando en esto, sabemos que la videoconferencia en RDSI, y SIP lleva ya tiempo funcionando. De hecho en alta definición ya habí­a hace años productos de Cisco, Tandberg o Polycom.

Pero ha tenido que ser Steve Jobs, el que muestre una videconferencia distinta, una videconferencia basada en SIP y con algo más de calidad, por no tener que pasar por el canuto reducido del 3G, y con un coste cero…

Cuantas videollamadas 3G he hecho en mi vida? Creo que 3 o 4 y casi todas de pruebas.. Con mi mujer en algún viaje llegué a hacer alguna de ellas para ver a mi hijo Alberto

Ahora sé, que con Daniel, será todo más fácil y se le verá algo mejor..

Que despegue de una vez la videoconferencia! 🙂 Qué ya era hora!

Ví­deo de FaceTime aquí­

Aplicaciones de la videollamada: Videinterpretación

17 Mar

Interesante proyecto español (http://svisual.org/) que permite por videollamada, realizar llamadas por personas sordas, a cualquier número con un intérprete visual que convertirá de lenguaje de signos a voz y viceversa.

El sistema funciona tanto mediante webcam por web, como por teléfono con capacidades de videollamada 3G así­ como por videoteléfono SIP!.

Una de esas aplicaciones que parecen “simples”, pero que pueden facilitar la vida a mucha gente.

Más información aquí­