Curso Asterisk Advanced en Chile de la mano de USA VOIP

24 Jun

Cabecera-SC-Agst

De la mano de USA VOIP se celebrará un Asterisk Advanced los días 24 al 28 de Agosto en Chile.

En esta ocasión he sido invitado para impartir dicha formación , será una de las ocasiones únicas y esperemos que repetidas en el futuro para recibir formación de Asterisk al otro lado del atlántico.

Captura de pantalla 2015-06-24 a las 10.02.46

El precio del curso es de 2000 dólares sin material y 2300 con material, y si formalizáis la reserva hasta finales de Julio tenéis un descuento de 300 dólares adicional.

El materíal incluído en el curso (Opción con material) es :

– 1 tarjeta Digium PRI TE133 o similar

– 1 tarjeta Digium analógica TDMP410 o AEX410

– 1 Modulo FXS 1S110M y 1 Módulo FXO 1XM100M

– 1 Teléfono IP Digium D40

– Documentación curso y prácticas formato papel

Si estáis interesados podéis contactar conmigo o bien hacerlo directamente aquí

Nos vemos en Chile!

Oferta Empleo Asterisk Alicante

28 Apr

Si estáis interesados en trabajar con Asterisk y residis en Alicante o planteáis hacerlo, tenéis una oferta interesante de la empresa Fabergroup cuyos requisitos os dejo a continuación:

Ingeniero VoIP con conocimientos de Asterisk, 3CX, gateways, protocolo SIP, administración de sistemas Linux y redes. Las tareas a realizar comprenderán la instalación y configuración de centralitas y el mantenimiento de la infraestructura de operador. Persona con iniciativa, capacidad de trabajo en equipo y dotes de organización y liderazgo.
 
Se valorará certificación dCap, certificaciones 3CX así como experiencia en algún lenguaje de programación.
Podéis contactar con ellos en comercial@fabergroup.es.
Mucha suerte!

Orange lanza su servicio de centralita IP

15 Apr

Los operadores tradicionales mueven ficha y empiezan a lanzar un todo en uno para empresas que incluye la conexión a Internet,  servicio de centralita Ip y teléfonos fijos.

Centralita IP integra en un único equipo internet, wifi y servicios de telefonía IP, así como todas las llamadas a fijos y móviles nacionales en una única cuota al mes de 75,95€

Entre los servicios de centralita IP figuran: plan privado de numeración, operadora automática con locuciones personalizables por el cliente, supervisión de estado de usuarios, transferencias, conferencias, buzón de voz entre otros.

Centralita IP facilita dispone de un acceso web para realizar todos los cambios y reconfiguraciones necesarias en tiempo real. Tambien puede  conectar el equipamiento actual de cliente, como teléfonos analógicos, fax o alarma.

 Existen dos teléfonos disponibles

Teléfono IP Premium: Con display LCD de 3 líneas, hasta 9 líneas simultáneas, teclas LED configurables por el usuario, manos libres “full duplex”, calidad de audio HiQ y  switch integrado para conexión del PC.

Teléfono IP Avanzado: Con display LCD, hasta 2 líneas simultáneas, teclas de función, manos libres “full duplex”, calidad de audio HiQ y  switch integrado para conexión del PC.

Más información en http://m.orange.es/empresas/solo-para-pymes/fijo/conecta-pymes/

Priorizar la VozIP usando Mikrotik

29 Mar

Si dispones de un router Mikrotik quizá te interese priorizar la Voz IP de tal modo que aunque hagas un uso intensivo del (upload) no afecte a la calidad del audio.

Con fibra la verdad es que salvo casos muy extraños es complicado que te encuentres con ese problema , que era más habituales con conexiones de upload reducido, como adsl o similares.

No obstante la configuración es bastante sencilla y solventará este problema si se presentara.

Tenemos dos opciones, si bien conoces la ip fija del dispositivo o centralita IP puedes marcar los paquetes de dichas ips, o bien usando el etiquetado DSCP , y configurando el terminal para que etiquete los paquetes, usaremos esa opción para aquellos terminales que dispongan de dicha funcionalidad. En el ejemplo usaremos el DSCP 48 para SIP y RTP. Hay dispositivos que marcan con DSCP distinto SIP o RTP , y realmente para la voz lo que nos preocupa es RTP, pero bueno por simplicidad considero el mismo etiquetado para ambos protocolos.

Primero crearemos unas reglas para marcar los paquetes como comentaba:

/ip firewall mangle

add action=mark-packet chain=prerouting comment=VOIP new-packet-mark=voip-mark passthrough=no protocol=udp src-address=10.0.0.2

add action=mark-packet chain=prerouting comment=VOIP dst-address=10.0.0.2 new-packet-mark=voip-mark  protocol=udp

add action=mark-packet chain=prerouting comment=VOIP dscp=48 new-packet-mark=voip-mark

add action=mark-packet chain=prerouting comment=VOIP new-packet-mark=bulk packet-mark=!voip-mark passthrough=no

Posteriormente crearemos las colas correspondientes para que una vez marcados los paquetes se encolen con las consideraciones de que VOIP será mas prioritario que el resto de tráfico (bulk)

/queue tree

add name=Cola_Principal parent=PPOE_CASA priority=1

add limit-at=1M max-limit=2M name=Trafico_VOIP packet-mark=voip-mark parent=Cola_Principal priority=1 queue=ethernet-default

add limit-at=8M max-limit=10M name=Trafico_Bulk packet-mark=bulk parent=Cola_Principal queue=ethernet-default

Si todo va bien veremos matches en las colas como os muestro:

Captura de pantalla 2015-03-29 a las 18.14.49

Barcelona WebRTC Meetup

30 Jan

global_432745515.jpeg

Para todos aquellos que andáis interesados en WebRTC y/o fascinados por esta nueva tecnología que lleva las comunicaciones unificadas al navegador, tenéis un evento que no os podéis perder el día 4 de Marzo de 2015 en Barcelona.

El evento tendrá lugar en :

Poblenou campus Auditorium – Universitat Pompeu Fabra (UPF)

y la agenda del evento completa la podéis localizar en este enlace

Un evento imprescindible. No os lo perdáis!. Para apuntaros podéis hacerlo en el link del evento

Llamadas de Voz Fija en Móvil: MiFijo 2.0 en Fibra Movistar FFTH

26 Jan

Los que sois un poco más avezados ya habréis configurado vuestra cuenta de teléfono en un softphone o centralita IP.

Para los que esto se os escapa un poco , que sepáis que Movistar tiene una aplicación llamada Fijo 2.0, aunque todavía está en beta, para hacer esto .

En mis pruebas es necesario hacerlo con el router comtrend y conectándose a su wifi, yo uso un mikrotik y no he conseguido echar a andar la famosa “vlan3” fuera del router que provee Telefónica.

En las capturas de la señalización SIP que lanza el programa para android se puede ver que es un LinphoneAndroid/0.4-46-g93fb3bb (belle-sip/1.3.3) 🙂

Para aquellos que queráis ampliar información os dejo el siguiente enlace.

 

Feliz 2015

31 Dec

Unas palabras antes de que termine este año.  Cierto es que he perdido un poco de fuelle bloguero, el trabajo,  la familia y todas esas excusas que se suelen poner me han tenido bastante ocupado.

Gracias por estar ahí como años anteriores y a voz.com por su apoyo incondicional este tiempo.

Un fuerte abrazo

Alberto

Skype ahora con webRTC (Beta)

14 Nov

Skype abraza el maná de las comunicaciones del futuro como es el WebRTC. Aunque todavía se encuentra creciendo es un protocolo que pretende dar guerra en el futuro, hoy quizá todavía hay mucha lucha entre grandes “fabricantes” para imponer su forma de hacer Real Time Communications sobre Web.

Skype lanza su versión Web en beta (dentro unas semanas disponible) donde ya no hace falta instalar nada para videochatear, sólo un navegador.sfw2

Microsoft tiene su propio “fork” de WebRTC que usará Internet Explorer (¿Alguien lo usa? :))

Más información en el blog de skype

 

Cómo montar tu propio túnel IPv6 con OpenVPN

1 Mar

Siguiendo un poco con el post anterior sobre Proxmox, quizá necesitéis para vuestros proyectos de voz ip direccionamiento IPv6 pero vuestro operador no os lo ofrece, tampoco os fiáis de usar un tunnelbroker como sixxs.net o el de Hurricane Electric por aquello de que no sabéis por donde pasa vuestro tráfico y preferís tener vuestro propio túnel. Entonces este tutorial os servirá porque es lo que estáis buscando 🙂

En mi caso lo hice, primero por  aprender ;), por lo de fiarme o no de por donde viaje mi tráfico IPV6 (al usar un túnel lo enviáis a una dirección IPv4 de alguien que os lo transporta a IPv6) , tampoco era una preocupación, pero bien , siempre es mejor controlar por donde enviáis información, y cuantos menos saltos tengáis, mejor latencia en IPV6 tendréis.

Al usar tunnelbrokers la latencia se verá aumentada en la latencia que tengáis desde vuestra conexión al POP que os da la traslación a IPv6. Es decir si tenéis 50 ms a vuestro POP o servidor OpenVPN en nuestro caso, la latencia a chico.rediris.es por ejemplo, será de 50 ms+ la latencia de vuestro servidor al host destino, en el caso de online.net que es el que aquí ilustro, unos 29 ms más. Es decir estaremos entorno a los 80-90 ms al espacio de direcciones IPv6.

Si elegís un servidor o VPS con mejor latencia, esto os redundará en mejor latencia a direcciones IPv6 , en las que la navegación o aplicaciones sensibles a la latencia/Jitter como es la Voz sobre IP, se verán mejoradas.

40

El Ayuntamiento de Ciudad Real se pasa a la voz sobre IP

26 Feb

Cada vez son más ayuntamientos que para ahorrar costes y mejorar la atención l los ciudadanos migra a voz sobre IP. Casos que conozca personalmente son el Ayuntamiento de Ávila, y hay muchos más por la zona del Levante de los cuales tengo referencias.

Son buenas noticias para el sector, y sobre todo porque van en el camino de disminuir el déficit que muchos de nuestros ayuntamientos tienen , por tener soluciones propietarias que tienen un recurrente de mantenimiento del cual no pueden prescindir, cosa que con la voz sobre IP, se puede encargar un departamento de informática formado al respecto.

Vía eldiadigital.es