Cómo configurar un Mikrotik para usar la vlan3 de voip de Movistar FFTH

26 Feb

Para los que la vozip es una pasión, lo de usar la voz mediante el puerto FXS de la ONT se nos queda pobre, mucha gente para integrar líneas de FFTH en centralitas suele usar un adaptador FXO conectado al FXS , y de esta forma integrarlo en la centralita IP.

Pero esto aunque funciona no es lo óptimo, porque gastarse más dinero en gateway cuando podemos atacar directamente a la plataforma de Movistar a nivel SIP.

Para ello podemos hacer dos cosas, conseguir migrar de alguna forma a sbc.ngn.rima-tde.net nuestra cuenta de fijo, por ejemplo una de las vías es apuntarse a la beta de Mi Fijo 2.0 que conté hace unos días y solicitar el poderla usar fuera de la conexión de fibra. Nos proporcionarán un usuario y en un post posterior mostraré como configurarlo con una centralita comom Asterisk.

La segunda sería sustituir el router de Movistar y atacar directamente con un Mikrotik. Para ello debemos crear dos vlanes (6 Datos y 3 Voz) , si dispusiéramos de Movistar TV haría falta configurar la vlan2 también, pero eso es otro asunto.

Os muestro la configuración necesaria a continuación.

Creamos las dos vlanes:

add interface=ether1-ont-casa l2mtu=1594 mtu=1594 name=vlan3 vlan-id=3

add arp=proxy-arp interface=ether1-ont-casa l2mtu=1594 mtu=1594 name=vlan6 \
vlan-id=6

Habilitar cliente DHCP por la vlan3

add add-default-route=no dhcp-options=hostname,clientid disabled=no \

interface=vlan3 use-peer-dns=no use-peer-ntp=no

Permitir tráfico vlan3 por el firewall y realizar NATeado

/ip firewall filter

add chain=input in-interface=vlan3

add chain=output out-interface=vlan3

add action=masquerade chain=srcnat out-interface=vlan3

Habilitar los SIP ports

/ip firewall service-port

set sip ports=5060,5061,5070

Y añadir las reglas de rutado por la vlan3

/ip route

add distance=1 dst-address=10.31.255.128/27 gateway=10.22.0.1%vlan3 \
routing-mark=to_vlan3

/routing rip interface

add interface=vlan3 passive=yes receive=v2

/ip firewall mangle

add action=mark-connection chain=prerouting dst-address=10.31.255.128/27 \

in-interface=bridge-local new-connection-mark=voip_vlan3 src-address=\

10.0.1.8 (Aquí la 10.0.1.8 es una centralita IP o teléfono IP)

add action=mark-routing chain=prerouting connection-mark=voip_vlan3 \

in-interface=bridge-local new-routing-mark=to_vlan3

add action=mark-routing chain=output connection-mark=voip_vlan3 \

new-routing-mark=to_vlan3

y luego las rutas corresponidentes

/ip route

add distance=1 dst-address=10.31.255.128/27 gateway=10.22.0.1%vlan3 \

routing-mark=to_vlan3

Con esto cuando vayamos a registrar un teléfono IP o centralita, usaremos los datos

IP de registro: telefonica.net:5060

Proxy: 10.31.255.134:5070

Usuario: 9XXXXXXXX

Password : 9XXXXXXXX ( El mismo número)

Codecs Soportados: G722, G711 , G729 ,H264,H263 y H263p

Cualquier duda, dejarla en comentarios

6 thoughts on “Cómo configurar un Mikrotik para usar la vlan3 de voip de Movistar FFTH

  1. Hola,

    Muchas gracias por la explicación, tengo un mikrotik con movistar y un freepbx.

    El problema que tengo es que cuando hago ping a: 10.31.255.134 me da timeout.

    ¿Me podrías explicar de donde sacas la IP 10.22.0.1 y por qué marcas en trafico? En la ruta que hay que añadir:

    /ip route
    add distance=1 dst-address=10.31.255.128/27 gateway=10.22.0.1%vlan3 routing-mark=to_vlan3

    Gracias!

  2. Si tu ONT dispone de conexión RJ11 (la de teléfono) puedes conectar directamente el teléfono analógico ahí pero actualmente movistar está cambiando las ONT por otras mas pequeñas y la conexión con la línea de teléfono se realiza con el router de movistar. Si vamos a cambiar dicho router por uno de mikrotik, ¿donde conectamos el teléfono ahora ya que la ONT no dispone de dicha conexión?

    Saludos.

  3. Buscando como configurar la voip de la fibra de movistar vi tu review del cisco spa 112, como mi teléfono actual está enchufado al router a través de un rj11, crees que dicho adaptador enchufado a un puerto Lan de un router en condiciones podría darme línea de teléfono. Es que no se como cambiar el router ya que como he dicho, el teléfono está enganchado al router de movistar y el ont no tiene para enganchar el teléfono. Gracias!!!

  4. pues la verdad es que me vendría bien toda la informacion posible ya que en cuanto creo el segundo dhcp client el primero deja de entregarme la ip, es decir, el ultimo que activo es el unico que me entrega ip

  5. Hola Jose

    Si se podría si tienes dos ONT cada una a un puerto. Lo que si puede ser que haga falta es que etiquetes el tráfico para dilucidad por que vlan3 salir si la de la ONT1 o ONT2. Hice pruebas con esto por si necesitas ayuda

    Saludos

  6. Muy interesante la información, llevaba tiempo buscando algo parecido.

    Una pregunta, podrían configurarse dos voip de movistar en un solo mikrotik?

Leave a Reply

Your email address will not be published. Required fields are marked *