29 mar

Priorizar la VozIP usando Mikrotik

Si dispones de un router Mikrotik quizá te interese priorizar la Voz IP de tal modo que aunque hagas un uso intensivo del (upload) no afecte a la calidad del audio.

Con fibra la verdad es que salvo casos muy extraños es complicado que te encuentres con ese problema , que era más habituales con conexiones de upload reducido, como adsl o similares.

No obstante la configuración es bastante sencilla y solventará este problema si se presentara.

Tenemos dos opciones, si bien conoces la ip fija del dispositivo o centralita IP puedes marcar los paquetes de dichas ips, o bien usando el etiquetado DSCP , y configurando el terminal para que etiquete los paquetes, usaremos esa opción para aquellos terminales que dispongan de dicha funcionalidad. En el ejemplo usaremos el DSCP 48 para SIP y RTP. Hay dispositivos que marcan con DSCP distinto SIP o RTP , y realmente para la voz lo que nos preocupa es RTP, pero bueno por simplicidad considero el mismo etiquetado para ambos protocolos.

Primero crearemos unas reglas para marcar los paquetes como comentaba:

/ip firewall mangle

add action=mark-packet chain=prerouting comment=VOIP new-packet-mark=voip-mark passthrough=no protocol=udp src-address=10.0.0.2

add action=mark-packet chain=prerouting comment=VOIP dst-address=10.0.0.2 new-packet-mark=voip-mark  protocol=udp

add action=mark-packet chain=prerouting comment=VOIP dscp=48 new-packet-mark=voip-mark

add action=mark-packet chain=prerouting comment=VOIP new-packet-mark=bulk packet-mark=!voip-mark passthrough=no

Posteriormente crearemos las colas correspondientes para que una vez marcados los paquetes se encolen con las consideraciones de que VOIP será mas prioritario que el resto de tráfico (bulk)

/queue tree

add name=Cola_Principal parent=PPOE_CASA priority=1

add limit-at=1M max-limit=2M name=Trafico_VOIP packet-mark=voip-mark parent=Cola_Principal priority=1 queue=ethernet-default

add limit-at=8M max-limit=10M name=Trafico_Bulk packet-mark=bulk parent=Cola_Principal queue=ethernet-default

Si todo va bien veremos matches en las colas como os muestro:

Captura de pantalla 2015-03-29 a las 18.14.49

26 feb

Cómo configurar un Mikrotik para usar la vlan3 de voip de Movistar FFTH

Para los que la vozip es una pasión, lo de usar la voz mediante el puerto FXS de la ONT se nos queda pobre, mucha gente para integrar líneas de FFTH en centralitas suele usar un adaptador FXO conectado al FXS, como Grandstream HT503 o similar , y de esta forma integrarlo en la centralita IP.

Pero esto aunque funciona no es lo óptimo, porque gastarse más dinero en gateway cuando podemos atacar directamente a la plataforma de Movistar a nivel SIP.

Para ello podemos hacer dos cosas, conseguir migrar de alguna forma a sbc.ngn.rima-tde.net nuestra cuenta de fijo, por ejemplo una de las vías es apuntarse a la beta de Mi Fijo 2.0 que conté hace unos días y solicitar el poderla usar fuera de la conexión de fibra. Nos proporcionarán un usuario y en un post posterior mostraré como configurarlo con una centralita Grandstream por ejemplo.

La segunda sería sustituir el router de Movistar y atacar directamente con un Mikrotik. Para ello debemos crear dos vlanes (6 Datos y 3 Voz) , si dispusiéramos de Movistar TV haría falta configurar la vlan2 también, pero eso es otro asunto.

Os muestro la configuración necesaria a continuación.

Creamos las dos vlanes:

add interface=ether1-ont-casa l2mtu=1594 mtu=1594 name=vlan3 vlan-id=3

add arp=proxy-arp interface=ether1-ont-casa l2mtu=1594 mtu=1594 name=vlan6 \
vlan-id=6

Habilitar cliente DHCP por la vlan3

add add-default-route=no dhcp-options=hostname,clientid disabled=no \

interface=vlan3 use-peer-dns=no use-peer-ntp=no

Permitir tráfico vlan3 por el firewall y realizar NATeado

/ip firewall filter

add chain=input in-interface=vlan3

add chain=output out-interface=vlan3

add action=masquerade chain=srcnat out-interface=vlan3

Habilitar los SIP ports

/ip firewall service-port

set sip ports=5060,5061,5070

Y añadir las reglas de rutado por la vlan3

/ip route

add distance=1 dst-address=10.31.255.128/27 gateway=10.22.0.1%vlan3 \
routing-mark=to_vlan3

/routing rip interface

add interface=vlan3 passive=yes receive=v2

/ip firewall mangle

add action=mark-connection chain=prerouting dst-address=10.31.255.128/27 \

in-interface=bridge-local new-connection-mark=voip_vlan3 src-address=\

10.0.1.8 (Aquí la 10.0.1.8 es una centralita IP o teléfono IP)

add action=mark-routing chain=prerouting connection-mark=voip_vlan3 \

in-interface=bridge-local new-routing-mark=to_vlan3

add action=mark-routing chain=output connection-mark=voip_vlan3 \

new-routing-mark=to_vlan3

y luego las rutas corresponidentes

/ip route

add distance=1 dst-address=10.31.255.128/27 gateway=10.22.0.1%vlan3 \

routing-mark=to_vlan3

Con esto cuando vayamos a registrar un teléfono IP o centralita, usaremos los datos

IP de registro: telefonica.net:5060

Proxy: 10.31.255.134:5070

Usuario: 9XXXXXXXX

Password : 9XXXXXXXX ( El mismo número)

Codecs Soportados: G722, G711 , G729 ,H264,H263 y H263p

Cualquier duda, dejarla en comentarios

24 feb

Webinars sobre Voz IP

Avanzada7 ha publicado los vídeos de los webinars que viene realizando desde 2012, lo que es una interesante fuente de conocimiento para conocer fabricantes, productos y tecnología de la mano de unos de los distribuidores con más experiencia en España y Europa.

Podéis encontrar los vídeos aquí y tenéis organizado por años los vídeos en el siguiente enlace.

30 ene

Barcelona WebRTC Meetup

global_432745515.jpeg

Para todos aquellos que andáis interesados en WebRTC y/o fascinados por esta nueva tecnología que lleva las comunicaciones unificadas al navegador, tenéis un evento que no os podéis perder el día 4 de Marzo de 2015 en Barcelona.

El evento tendrá lugar en :

Poblenou campus Auditorium – Universitat Pompeu Fabra (UPF)

y la agenda del evento completa la podéis localizar en este enlace

Un evento imprescindible. No os lo perdáis!. Para apuntaros podéis hacerlo en el link del evento

26 ene

Llamadas de Voz Fija en Móvil: MiFijo 2.0 en Fibra Movistar FFTH

Los que sois un poco más avezados ya habréis configurado vuestra cuenta de teléfono en un softphone o centralita IP.

Para los que esto se os escapa un poco , que sepáis que Movistar tiene una aplicación llamada Fijo 2.0, aunque todavía está en beta, para hacer esto .

En mis pruebas es necesario hacerlo con el router comtrend y conectándose a su wifi, yo uso un mikrotik y no he conseguido echar a andar la famosa “vlan3″ fuera del router que provee Telefónica.

En las capturas de la señalización SIP que lanza el programa para android se puede ver que es un LinphoneAndroid/0.4-46-g93fb3bb (belle-sip/1.3.3) :)

Para aquellos que queráis ampliar información os dejo el siguiente enlace.

 

2 ene

Sangoma apuesta fuerte y compra FreePBX

logo

 

Movimiento  importante en el panorama VOIP como es la compra del interfaz web por excelencia , FreePBX por parte de sangoma.

El coste de la operación ronda los 4 millones de dólares, 1 millón en acciones de Sangoma y millón y medio en un variable si ciertos objetivos son alcanzados.

Con una empresa importante como sangoma apostando por FreePBX, ahora que Elastix se independiza del uso de FreePBX en las últimas versiones de Elastix , es un movimiento importante que sólo el tiempo aclarará quien se lleva el gato al agua.

De igual forma adquiere la empresa RockBochs que ofrece servicios en la nube de FoIP (Fax over IP).

Sin duda la noticia de finales de 2014. Qué más nos traerá este 2015?

Más información Nota de Prensa

31 dic

Feliz 2015

Unas palabras antes de que termine este año.  Cierto es que he perdido un poco de fuelle bloguero, el trabajo,  la familia y todas esas excusas que se suelen poner me han tenido bastante ocupado.

Gracias por estar ahí como años anteriores y a voz.com por su apoyo incondicional este tiempo.

Un fuerte abrazo

Alberto

15 dic

Port Knocking en tu Asterisk o Elastix

No hay que decir que la seguridad es un tema a tener en cuenta en cualquier sistema VoIP hoy en dia, una técnica bastante utilizada recientemente es el port knocking, que consiste enviar paquetes a algunos predefinidos que realizan una acción a nivel de iptables . Generalmente abriendo el puerto SSH a la ip remota desde la que se realiza el port knocking .

Es bastante habitual usarlo para SSH, pero puede ser bastante útil usarlo para SIP con el fin de abrir el registro temporalmente para registrar un endpoint sip y posteriormente cerrarlo, bien realizando la operación inversa o bien por timeout.

(más…)

14 nov

Skype ahora con webRTC (Beta)

Skype abraza el maná de las comunicaciones del futuro como es el WebRTC. Aunque todavía se encuentra creciendo es un protocolo que pretende dar guerra en el futuro, hoy quizá todavía hay mucha lucha entre grandes “fabricantes” para imponer su forma de hacer Real Time Communications sobre Web.

Skype lanza su versión Web en beta (dentro unas semanas disponible) donde ya no hace falta instalar nada para videochatear, sólo un navegador.sfw2

Microsoft tiene su propio “fork” de WebRTC que usará Internet Explorer (¿Alguien lo usa? :))

Más información en el blog de skype

 

10 nov

Curso Oficial Asterisk Advanced en Madrid 17-21 Noviembre 2014

Captura de pantalla 2014-11-10 a las 8.13.25La semana próxima tiene lugar el Curso Digium Asterisk Advanced en Torre Umbú (Madrid)

El temario ha sido actualizado a Asterisk 11 , así  que aquellos que obtengan el DCAP tendrán el DCAP más actualizado a día de hoy :)

En esta ocasión seré yo el que imparta este curso, así que aquellos que deseéis apuntaros podéis hacerlo a través de Avanzada7 solicitando información en este enlace

Si formalizáis la reservar indicar que vísteis la información en VOIPNOVATOS :)

Saludos

30 oct

Comienza la ElastixWorld 2014 en Santiago de Chile

Si Astricon es la feria Asterisk por antonomasia, Voip2day la feria de la VoIp en Europa, ElastixWorld es la feria más importante del mundo Elastix en el mundo.

En menos de un mes se concentran los tres eventos que hacen saltar de un lado al otro del mundo a los ponentes más solicitados.

Este año tiene lugar en Santiago de Chile con un elenco de ponentes entre los que se encuentran amigos y gente admirada.

Algún año espero tener la suerte de poder participar, este año Voipnovatos se quedó a las puertas :)

Durante hoy seguramente será liberada Elastix 3.0 cuya renovación es de las más importantes que ha tenido Elastix. Ya sólo el incorporar un SIP Proxy delante de Asterisk es de total valentía .

(Ya ha sido liberada la 3.0 estable aquí)

Captura de pantalla 2014-10-29 a las 8.14.44

Podéis seguir el evento en sus cuentas de twitter @elastixworld y en el hashtag #elastixworld

27 oct

Crear una red IPV6 para pruebas con VoIP

Muchos de vosotros (yo incluido) no tendréis ipv6 de forma nativa en vuestra conexión a internet, aunque en algunos países si que es así, sobre todo del norte de Europa, o al otro lado del charco.

Sin embargo a nivel de CDN y en servidores dedicados es ya una realidad, de hecho hace poco DigitalOcean anunció soporte para #ipv6.

Considerando que tenemos ese primer paso , teniendo un servidor dedicado o virtual con conexión ipv6, usaremos OpenVPN para “traernos” la ipv6 al otro extremo y rutar dicho tráfico ipv6 través de nuestro servidor dedicado.

¿Por qué no usar un tunnel broker como HE o Sixxs.net?

Lo usé en el pasado y aparte de no tener mucho ancho de banda de salida, siempre te cabe la duda de por donde pasa lo que envías. Generalmente son tunnels ofrecidos por operadores pero no siempre es así. Me quedo más tranquilo enviando mi tráfico ipv6 por un sitio que conozco .

Nada me asegura que en el otro extremo alguien lo esté inspeccionado, pero al menos no pasa por tantos sitios. La desventaja es que quizá el POP (Punto de presencia) que será nuestro servidor dedicado puede no estar a una latencia mínima desde nuestra conexión. Pero siempre podemos incluso tener varios hasta que demos con el que mejor nos funcione.

En el caso de online.net os recomiendo esta guía para echar a andar ipv6 (mejor que dibbler).

(más…)